Collection viewer: endpoint may not support REST API


#1

Hi

I’m doing some experiments with omeka classic 2.6.1 and collection viewer. I’ve been able to setup everything in a local LAN. I installed OmekaCollectionViewer on a win7 64bit PC. I edited OmekaCollectionViewer.cml adding my webserver IP and I enabled API from admin dashboard. But I’m still having URL error: the provided endpoint may not support the Omeka Rest API.
What’s wrong ?

thanks


#2

It’s a bit difficult to tell from here, but we’ve been alerted to the fact that the collections viewer and mobile apps were not set up to accommodate https endpoints. The developers at Ideum, who did the work on those applications, are working on an update, but we don’t have an ETA. So, one, not ideal, solution might be to switch to http, if that’s an option.


#3

Thanks for your answer SharonLeon .
I’m really new to omeka and I’ve, of course, a lot of questions.
When you say “switch to http it’s an option” do you mean to use http instead of https in OmekaCollectionViewer.cml endpoint section ?
If this is the case I’ve already tried with no success.
Is there any way to check if REST API are really made available by the omeka web server ?
Is there any known compatibility issue between omeka 2.6.1 and CollectionViewer ?

Thanks again


#4

Hi cajolo,

Changing the URL in the Omeka Collections file won’t work. You’d have to change the actual Omeka domain on the server to use http rather than the secure TSL. https is mostly the default now since browsers check for it and alert users when that encryption isn’t being used.

There are no known issues about 2.6.1, but you can check your table connection by using http://omekaeverywheredemo.org/api/

Sharon


#5

Hi,

now I’m using http in ny omeka web server. In my omeka installation there isn’t any API folder under my apache document root. I’ve found it under /application/views/scripts/ then if I try to open http://myip/application/views/scripts/api/ the page says "This is the endpoint URL for the ".
I suppose this is the correct one. So, I put this url in OmekaCollectionViewer.cml endpoint section but I’m still having the same error.
Any additional suggestion ?

Thanks a lot


#6

And you’re sure that you’ve enabled your API under the Settings area in the admin?


#7

Yes, the checkbox “Enable API” is selected.


#8

Well, with that, we’ve reached the upper limits of my capacity to help, but I’m sure that someone else on the team can help you troubleshoot the issue with your installation.


#9

By the way, you wouldn’t have an /api/ directory in your file directory on your server if you were looking, but if you put the URL in your browser: http://yourdomain.org/api/ it should direct you to the base page api connection for the site and the resources.


#10

Hi, I modified the web server cfg and now if you open the URL http://myhost/api you get the correct api page. I modified OmekaCollectionViewer.cml with this URL.
But I’m still having the same “the provided endpoint may not support the Omeka Rest API”.
Any additional suggestion for troubleshoot this problem ?

Thanks


#11

Collection Viewer has been updated to support https. It is worth seeing if updating helps to resolve the issue.


#12

I’ve finally solved the problem. It was related to some specific setting in apache2 configuration. More details here Public site not accessible
Thanks to all for the support