Batch jobs don't work anymore

For some reasons (job stuck) batch jobs do not work anymore on one installation of Omeka S 2.0.2.

I tried to delete the content of table “job” in the mysql database but still no background job.

Any trick to fix it?

Are you sure that your PHP-CLI path is set correctly?

Yes. It was working until a job get stuck. Since that, only synchronous jobs for few items work.

Is there something to do inside the mysql database (other than deleting the list of job) to “reset” job management?

No, there really isn’t anything that would get “stuck” in the database side of things: each job is separate from every other in that system.

If you’re suddenly having issues with jobs where you didn’t before, I’d look at changes to your system or install that could be the culprit. What status are you having jobs get stuck at, Starting?

Yes jobs are in starting state.

I delete every job line in the mysql database, uninstall CSVImport (to clean database), reinstall CSVImport and try to import content. The job is always in “starting” state. It has the ID “26” so the system is not reset to the default and previous jobs are somewhat kept.

You mean it’s always job 26, or that it just used that ID after you had erased the existing lines? The “next ID” is separately stored in the database, so clearing out the existing rows wouldn’t necessarily cause you to get “1” as the first ID. What you’re seeing (assuming the IDs continue to go up for further jobs) is expected behavior.

It is just the ID after I erase the existing lines.
So it is expected behavior.

I change the number of line to batch import inside CSVImport (it was 20, now it is 1). Somehow it is working now (and the batch delete to). It is possible it was a server issue.