Bad links on public page


#1

We have attempted to move our Omeka-2.4.1 installation following a system crash to a new server. We have installed Omeka-2.5.1. We have uploaded the database files and support files as directed in the site:

https://omeka.org/classic/docs/Technical/Moving_to_Another_Server/

At the present time, the public page comes up, however all of the navigation buttons (“Browse Items”, “Browse Collections”, “Map”, “Browse Exhibits” and “About” are broken. They all result in a page with the message "Not found; The requested URL … " was not found on this server.

Indeed, the link references do not exist in the Omeka Installation when reviewing the installation with the command-line interface. For example, the file /var/www/html/omeka-2.5.1/items/browse does not exist although the main public page is calling it.

Other posts, notably “Still getting 404 errors messages” (Still getting 404 errors messages) and others suggest that there is the need to modify the ‘Allow Overrides’ directives in /etc/apache2.conf.

It appears that changing any of the directives from ‘AllowOverride None’ to ‘AllowOverride All’ completely crashes the site; the public page will not come up. We then have tried every permutation of of AllowOverride as well as variants of: ‘Require all granted’ and ‘Require all denied’, with the same result. If ‘AllowOverride None’ is in force, the public page will come up but the links are broken.

We have also experimented with the lines following “The following lines prevent .htaccess and .htpasswd files from being viewed by web clients”. There are three lines, we have changed the default ‘Require all denied’ to ‘Require all granted’ as well as commenting out all three lines.

There is a file on our site /var/www/html/omeka-2.5.1/.htaccess. We have experimented with the debugging settings in that file all to no avail.

We have tried all available combinations as noted running mysql Ver 14.14 Distrib 5.7.20 as well as with the latest mariadb packages. We have installed, and reinstalled the entire Ubuntu server experimenting with as many settings that we can identify as possible, all to no avail. Among other things, we have changed the permission of all files and directories below /var/www/ to 777 to insure that the files are ‘writable by the server’. We have installed and uninstalled many suites of PHP packages as well.

Is there anything else that can be done to get Omeka-2.5.1 to run? Are the buttons “Browse Items”, “Browse Collections” &c. incorrectly coded?

We previously ran Omeka 2.4.1 on our Microsoft Azure/Ubuntu 16.04 server with no incident until we experienced a site crash.

Thanks in advance for your help.


#2

Figured out access after several more hours of troubleshooting.

  1. Use the stock .htaccess file that comes with the omeka-2.5.1 bundle.
  2. Change one of the AllowOverride directives so it reads exactly:

less than Directory slash greater than
Options FollowSymLinks
AllowOverride All
Require all granted
less than slash Directory greater than

(Leave all the other AllowOverride directives commented out.)
3) Run the a2enmod command as root, e.g. ‘sudo a2enmod’.
4) Other thoughts that we did earlier:
Change the ownership permissions of the entire installation so they are under one owner. If the site owner is ‘joe’ then
sudo chown -R joe ./admin and so on for all the other directories within the installation.
Change the permissions of the entire installation to ‘777’. While not obvious, you do need the write permission to items you think you would need read permission for.
5) Generate a very complex 64-bit password for the site!

Summary

This text will be hidden